Home | Search | Login | RSS
We have 1080 members and counting!
Next Page

1

Previous Page

Thread: Upgrade of 3.5.3 ..

Created on: 04/24/12 01:10 PM

Replies: 5

Fenryll





Joined: 03/15/09

Posts: 25

Upgrade of 3.5.3 ..
04/24/12 1:10 PM

Hi everybody,

I hope it won't sound too sutpid :) basically I learned here about FMS and migrated my own online card from a previous custom java solution to FMS.

It was such a success, so stable, that I more or less let it run since then (doing that on my spare time).

Today (2 years after..) just had that idea to see what happened to that product and landed on this page: http://www.adobe.com/support/flashmediaserver/downloads_updaters.html where I saw there are free update available till version 4.5.2...

My question now (finally): I have a development environment on my windows laptop and a production one on a robust hosted linux server, and I am far to be a linux guru... how easy it is to go from my 3.5.3 to the 4.5.2 on the linux production ? Is there any real added value for me ? Is it risky ? Do I have to plan a big downtime ? Do I have to change any code ? Roll back will be possible ?

Sorry if that sounds like a newb or lazy question :)

Link | Top | Bottom

Graeme





Joined: 10/18/07

Posts: 1593

RE: Upgrade of 3.5.3 ..
04/24/12 10:33 PM

Unless you need the features of 4.5, I wouldn't bother. Essentially, if it isn't broken then I wouldn't "fix" it.

To upgrade isn't that difficult though, you just have to make sure you manually update your XML files in the conf folder and any you have in each application folder if you have one in there. No changes to code. Roll back shouldn't be an issue if you keep the XML files from the original install.

Link | Top | Bottom

Fenryll





Joined: 03/15/09

Posts: 25

RE: Upgrade of 3.5.3 ..
04/25/12 12:54 AM

Thank you Graeme,

I like your first advice, and no it is not broken, it is running flawlessly :) (thank to that marvelous product and your great tutorial)

Reading the second part of your message reassure me anyway, if I understand correctly, no existing file (code) are overwritten, only the conf files to point on the new code, right ?

I may look more into it and once rollback procedures are secured give it a try, thanks

Link | Top | Bottom

Fenryll





Joined: 03/15/09

Posts: 25

RE: Upgrade of 3.5.3 ..
03/05/13 12:57 PM

Hi there,

1 year later I reopen this post: I was reported some problems on my game those last weeks, finally I opened the core.log file and find out entries log corresponding to the problems time:

Assert failed in /FlashPlayer6_02_FlashCom/shared_tcserver/tcparser.cpp line 109

After some googling, I read that article were the advise is to update to 3.5.7
http://forums.adobe.com/message/4120260

So I decided to update and today I migrated my users on a temporary server to ensure service continuity while I will take care of the update.

two questions here:
1) My 3.5.3 license allows me to update to which version ? should I go to 3.5.7, or am I allowed to install higher ? 4 or 4.5 ?

2) what is the best way to update ? hard to find something better than http://help.adobe.com/en_US/flashmediaserver/install/WS5b3ccc516d4fbf351e63e3d119ed5bf6c6-7ff2InstallConfigure.html where apparently you stop - backup - uninstall old version - reinstall new version ?

Thanks
* Last updated by: Fenryll on 3/5/2013 @ 12:58 PM *

Link | Top | Bottom

Fenryll





Joined: 03/15/09

Posts: 25

RE: Upgrade of 3.5.3 ..
03/08/13 1:20 AM

Okay, let close this one... finally I invested some money and upgraded to ams 5 to be quite for the next 5 years :)

Thanks anyway

Link | Top | Bottom

Graeme





Joined: 10/18/07

Posts: 1593

RE: Upgrade of 3.5.3 ..
03/12/13 3:19 PM

Just to quickly cover how to update FMS to a newer version:

1. Backup all of conf and applications folders. Logs too if you want to make sure those are kept.

2. Install new version. It should prompt the removal of the old version

3. Copy back in all of your applications

4. Carefully, manually check each XML file in the applications and conf folders to make sure you are using the latest XML files but with the changes you may have applied. It's a pain.. but has to be done like this.

Link | Top | Bottom

Next Page

1

Previous Page

New Post

Please login to post a response.